question

Vikash P avatar image
Vikash P asked ·

Getting OAU-149 error

We are getting

"errorCode": "OAU-149",   "message": "Invalid token" 

While calling API. Access Token is absolutely correct we got after calling restapi/oauth/token

but still it gives that error.

tokenaccess_token
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

· Write an Answer
Anirban Sen Chowdhary avatar image
Anirban Sen Chowdhary answered ·

TokenInvalid OAU-149 cause due to various reason:

  • You token got corrupted, some space or unwanted character added into it unknowingly, or some character is missed while copying the token
  • The token is only valid for your sandbox environment but used in some other environment like production environment. Though the token is valid but invalid for production, Make sure you are not doing that.

I already answered this here in the community: https://forums.developers.ringcentral.com/questions/9525/tokeninvalid-oau-149-error.html

1 comment Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

yes.. got it.. token got corrupted while copying

0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.