question

pratap-s avatar image
pratap-s asked ·

GLIP API POST Message not found

Hi ,

I am trying to post message to glip group chat using curl command but I am getting always {"message":"Not Found"}.
I have given Glip permission under  Settings -> Oauth Settings -> Permission Needed

Below is the command which I am using: 

curl -H "Content-Type: application/json" -H "Authorization: Bearer $token" -X POST https://platform.devtest.ringcentral.com/restapi/v1.0/glip/posts -d'{ "groupId":"52626304005","text":"Hi there! Test message"}'
topic-default
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

alexey-sobolev avatar image
alexey-sobolev answered ·
Hi, Pratap. 

Are you sure, that group with id '52626304005' does exists?
Could you, please, provide list of your groups? (GET /restapi/v1.0/glip/groups)

Best regards,
Alexey Sobolev
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

pratap-s avatar image
pratap-s answered ·
Hi Alexey,

Getting this curl -XGET -i -H "Content-Type: application/json" -H "Authorization: Bearer $token" ' https://platform.devtest.ringcentral....'

HTTP/1.1 404 Not Found
Server: nginx/1.10.2
Date: Fri, 02 Jun 2017 10:43:09 GMT
Content-Type: application/json; charset=utf-8
Content-Length: 23
Connection: keep-alive
ETag: W/"17-5mp6bJHiwmgD8/Sf63qIPw"
X-Server-Name: sjc06-c01-hlb01
X-Request-Time: 0.080
X-Upstream-Server: 10.24.21.167:56314
X-Upstream-Status: 404
X-Upstream-HTime: 0.080
X-Upstream-RTime: 1496400189.474
X-Upstream-CTime: 0.000
X-Tcpinfo: 1000, 500, 10, 28960
X-Rate-Limit-Group: light
X-Rate-Limit-Limit: 50
X-Rate-Limit-Remaining: 49
X-Rate-Limit-Window: 60
RoutingKey: SJC11P01
RCRequestId: 44db02fa-4780-11e7-bf71-005056bb594d

{"message":"Not Found"}
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

alexey-sobolev avatar image
alexey-sobolev answered ·
Oh, ok.Our API is working only for users already registered in Glip (It's temporary limitation).
So you need to sign up via RC in Glip ( https://glip.devtest.ringcentral.com/). And after that API will start working.

Best regards,
Alexey Sobolev
5 comments Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Hi Alexey,

I am bit confused here. I have signed up for RIngcentral app and using other features too. Can you exactly let me know which email ID I should use to signup to the URL ( https://glip.devtest.ringcentral.com/)

1st Email id used to signup to Ringcentral I am using this user to get secret and access to generate the token
OR
2nd My User account email id under ringcentral. This user is my user visible within the organisation. 
0 Likes 0 · ·
You need to go to  https://glip.devtest.ringcentral.com/ (It's Glip sandbox). Then you need follow "Sign In" -> "Sign In With Ringcentral". Then you need to authorize in RC (by any method - by phone, by SSO and etc). After that you will be refirected back to Glip. Right after it our API will start working for you.
1 Like 1 · ·
Thanks let me try this. 
0 Likes 0 · ·
Thanks Alexey, it worked. I wonder if I can post messages to  https://app.glip.com/ instead of  https://glip.devtest.ringcentral.com/ using my current credential as my account is not yet moved to production. 
-1 Like -1 · ·
Nope, you cannot. Your devtest credential cannot be used in production.
0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.