question

priya-ranjan avatar image
priya-ranjan asked ·

oauth/token API not working for my new production account

I have got my main account production approval just yesterday. I have collected API KEY/SECRET for production and trying to run my ode on it. Very strange that i am getting error and the error part of the response is highlighted below.

"Date: Sat, 25 Feb 2017 09:18:03 GMT  Server: nginx/1.10.2
  WWW-Authenticate: Bearer realm="RingCentral REST API", error="invalid_client", error_description="[ThirdPartyAppAccess] permission required"
  Content-Language: en
  Content-Type: application/json; charset=UTF-8"

I also tried with API Explorer and getting following error

{
                  
"error": "invalid_grant", "error_description": "Invalid resource owner credentials." }
I was also not able to log at  https://service.ringcentral.com/login/enter.html?s=1210&localeId=en_US#/number for production account and it gave me the attached screen!!

Please help me asap as i have to graduate my company account to production as well next week.
topic-default
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Tyler Liu avatar image
Tyler Liu answered ·
Please send email to devsupport@ringcentral.com

It seems like an account permission issue.
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

priya-ranjan avatar image
priya-ranjan answered ·
Many thanks for the reply. I have already submitted the above problem details to  devsupport@ringcentral.com from my email account linked with the RingCentral account. Hope to get a reply today i.e. Monday.
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

vb avatar image
vb answered ·
For production password issue, please reset your password by clicking on " Forgot Password?" and follow the wizard. You could also reach RingCentral customer support or your account manager to guide you in resetting your production account password.
2 comments Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Thanks for the reply VB.

Seems there is issue with my account which has nothing to do with password. I have already reset the password and i am getting same error  error_description="[ThirdPartyAppAccess] permission required" again .



0 Likes 0 · ·
This error reads as though there is a mismatch of user credentials as compared to the account (either production or sandbox).

Have you updated the API Keys in your application to use your production API Keys as indicated for your app in the Developer Portal?

Have you updated the RingCentral Platform API Base URL you are using in your application code for production: https://platform.ringcentral.com (instead of RingCentral Sandbox API Base URL: https://platform.devtest.ringcentral.com )?

Have you tried logging into the RingCentral Account Portal in Production ( https://service.ringcentral.com ) using the user credentials you are attempting to use in your application? HINT: If you cannot login to the Account Portal, you cannot use those credentials for authentication with the API for that environment (either Sandbox or Production respectively).
0 Likes 0 · ·
Anirban Sen Chowdhary avatar image
Anirban Sen Chowdhary answered ·

The production url to call API is https://platform.ringcentral.com and sandbox url for API : https://platform.devtest.ringcentral.com

This is the common mistakes many people does. Also the credentials are different of production from sandbox environment. These credentials details will be send by support team once the application successfully pushed to production.

Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.