question

sangeetha avatar image
sangeetha asked ·

Please Help me to fix the bug

Test 1: authData.php Auth exception: Refresh token has expired Exception: curl_close(): 57 is not a valid cURL handle resource SDK HTTP Error at _https:// platform.devtest.ringcentral.com/restapi/oauth/token Response text: Previous: curl_close(): 57 is not a valid cURL handle resource #0 phar:///home/tamilwjv/public_html/demo/ring/ringapi/ringcentral.phar/ringcentral/ringcentral-php/src/Platform/Platform.php(214): RingCentral\SDK\Http\Client->send(Object(RingCentral\Psr7\Request)) #1 phar:///home/tamilwjv/public_html/demo/ring/ringapi/ringcentral.phar/ringcentral/ringcentral-php/src/Platform/Platform.php(301): RingCentral\SDK\Platform\Platform->sendRequest(Object(RingCentral\Psr7\Request), Array) #2 phar:///home/tamilwjv/public_html/demo/ring/ringapi/ringcentral.phar/ringcentral/ringcentral-php/src/Platform/Platform.php(123): RingCentral\SDK\Platform\Platform->requestToken('/restapi/oauth/...', Array) #3 /home/tamilwjv/public_html/demo/ring/ringapi/demo/ authData.php(43): RingCentral\SDK\Platform\Platform-
topic-default
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

kim avatar image
kim answered ·
Please provide which product/integration you are using?  Also - we are moving this thread to the Developer's Community. 
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

sangeetha avatar image
sangeetha answered ·
I'm using this for onbizlist.I'm beginner for the ringcentral sdk library.I just use the php library i run the demo file i got this error so i cant ableto move further.please help me to proceed further
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

benjamin-dean avatar image
benjamin-dean answered ·
It appears that your development server does not match the requirements of use for the PHP SDK. These are currently listed as:
  • PHP 5.5+
  • CURL extension
  • MCrypt extension
Could you provide the versions for each of these from your system (as well as the OS installed with version) so we can eliminate this as a possibility for the issue.
Share
1 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.